SHARE
PwnXSS  : Vulnerability XSS Scanner Exploit

PwnXSS is a powerful XSS scanner made in python 3.7.

Installing

Requirements:

  • BeautifulSoup4

pip install bs4

  • requests

pip install requests

  • python 3.7

Commands:

git clone https://github.com/pwn0sec/PwnXSS
chmod 755 -R PwnXSS
cd PwnXSS
python3 pwnxss.py –help

Usage

  • Basic usage:

python3 pwnxss.py -u http://testphp.vulnweb.com

  • Advanced usage:

python3 pwnxss.py –help

Main Features

  • crawling all links on a website ( crawler engine )
  • POST and GET forms are supported
  • many settings that can be customized
  • Advanced error handling
  • Multiprocessing support.✔️
  • ETC….

Screenshot